Pages

Tuesday, February 28, 2012

IEEE 802.1Q Tunneling


 IEEE 802.1Q Tunneling



I wanted to extend a test lab extended to a mini switch at my desk over corporate LAN.  Here is the setup and configure.  It is very neat, now i can connect to my Lab network VLAN 100 at my desk.


referenced Cisco Doc at http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/configuration/guide/dot1qtnl.html

Thursday, February 9, 2012


I wanted to configure a route to go over specific link in a case with multi-path, and found below info from Cisco Doc, and worked like a charm.  At one site, we have Nexus 7k, the router map had to be build with prefix rather than access-list.

So, the example is 
ip prefix-list LEAK-MAP seq 10 permit 10.1.1.0/24
route-map LEAK-10-1-1 permit 10
match ip address prefix-list LEAK-MAP
----
---Cisco IP Routing Protocol Commands: -

EIGRP Support For Leaking Routes
Configuring the leak-map keyword allows to advertise a component route that would otherwise be suppressed by the manual summary. Any component subset of the summary can be leaked. A route map and access list must be defined to source the leaked route.
The following is default behavior if an incomplete configuration is entered:
If the leak-map keyword is configured to reference a nonexistent route map, the configuration of this keyword has no effect. The summary address is advertised but all component routes are suppressed.
If the leak-map keyword is configured but the access-list does not exist or the route map does not reference the access list, the summary address and all component routes are sent.

Examples

The following example, starting in Global configuration mode, configures an administrative distance of 95 on interface Ethernet 0/0 for the 192.168.0.0/16 summary address:
Router(config)# router eigrp 1 
Router(config-router)# exit 
Router(config)# interface Ethernet 0/0 
Router(config-if)# ip summary-address eigrp 1 192.168.0.0 0.0.255.255 95 
The following example, starting in Global configuration mode, configures the 10.1.1.0/24 subnet to be leaked through the 10.0.0.0 summary address:
Router(config)# router eigrp 1 
Router(config-router)# exit 
Router(config)# access-list 1 permit 10.1.1.0 0.0.0.255 
Router(config)# ! 
Router(config)# route-map LEAK-10-1-1 permit 10 
Router(config-route-map)# match ip address 1 
Router(config-route-map)# exit 
Router(config)# interface Serial 0/0 
Router(config-if)# ip summary-address eigrp 1 10.0.0.0 0.0.0.255 leak-map LEAK-10-1-1 
Router(config-if)# end